APPETITE FOR DISCUSSION
Welcome to Appetite for Discussion -- a Guns N' Roses fan forum!

Please feel free to look around the forum as a guest, I hope you will find something of interest. If you want to join the discussions or contribute in other ways then you need to become a member. Registering is free and easy.

Cheers!
SoulMonster

Something is wrong with image embedding

Go down

Something is wrong with image embedding Empty Something is wrong with image embedding

Post by Soulmonster on Wed Mar 27, 2019 11:25 pm

At least in some posts. Seems to somehow mess with one of our scripts. I really don't know what is causing it, and hope it will sort itself out soon.
Soulmonster
Soulmonster
Tour plane captain

Admin & Founder
Posts : 8775
Plectra : 55815
Reputation : 780
Join date : 2010-07-05

Back to top Go down

Something is wrong with image embedding Empty Re: Something is wrong with image embedding

Post by Blackstar on Thu Mar 28, 2019 12:16 am

Which posts? Is it with the "host image" feature?
I haven't had a problem, but I'm using the "insert image" feature.
Blackstar
Blackstar
ADMIN

Posts : 1535
Plectra : 11686
Reputation : 66
Join date : 2018-03-17

Back to top Go down

Something is wrong with image embedding Empty Re: Something is wrong with image embedding

Post by Soulmonster on Thu Mar 28, 2019 9:10 pm

@Blackstar wrote:Which posts? Is it with the "host image" feature?
I haven't had a problem, but I'm using the "insert image" feature.

You can see it here: https://tinyurl.com/y3ojqgcd

Seems like the script we have for shortcuts are messing up when pictures are embedded (possibly when the host image feature is used, as you suggested).
Soulmonster
Soulmonster
Tour plane captain

Admin & Founder
Posts : 8775
Plectra : 55815
Reputation : 780
Join date : 2010-07-05

Back to top Go down

Something is wrong with image embedding Empty Re: Something is wrong with image embedding

Post by Soulmonster on Thu Mar 28, 2019 9:11 pm

Test: Izzy.

I am testing that the auto-link still work.

Test: Vicky Hamilton.

I am testing that the pop-up feature works.
Soulmonster
Soulmonster
Tour plane captain

Admin & Founder
Posts : 8775
Plectra : 55815
Reputation : 780
Join date : 2010-07-05

Back to top Go down

Something is wrong with image embedding Empty Re: Something is wrong with image embedding

Post by Soulmonster on Thu Mar 28, 2019 9:11 pm

So the scripts still work, at least.
Soulmonster
Soulmonster
Tour plane captain

Admin & Founder
Posts : 8775
Plectra : 55815
Reputation : 780
Join date : 2010-07-05

Back to top Go down

Something is wrong with image embedding Empty Re: Something is wrong with image embedding

Post by Soulmonster on Fri Mar 29, 2019 2:24 am

@Blackstar wrote:Which posts? Is it with the "host image" feature?
I haven't had a problem, but I'm using the "insert image" feature.

Where do you host your images? I will try to host them somewhere else, and then use the "insert image" feature, too, and see if that solves it.
Soulmonster
Soulmonster
Tour plane captain

Admin & Founder
Posts : 8775
Plectra : 55815
Reputation : 780
Join date : 2010-07-05

Back to top Go down

Something is wrong with image embedding Empty Re: Something is wrong with image embedding

Post by Soulmonster on Fri Mar 29, 2019 2:28 am

Just uploaded an image to https://nb.imgbb.com/ and then used the insert image feature...still doesn't work.
Soulmonster
Soulmonster
Tour plane captain

Admin & Founder
Posts : 8775
Plectra : 55815
Reputation : 780
Join date : 2010-07-05

Back to top Go down

Something is wrong with image embedding Empty Re: Something is wrong with image embedding

Post by Soulmonster on Fri Mar 29, 2019 2:29 am

Something is wrong with image embedding AhusHaBR9Gy0QUnM70Xy+20190329_141656
Soulmonster
Soulmonster
Tour plane captain

Admin & Founder
Posts : 8775
Plectra : 55815
Reputation : 780
Join date : 2010-07-05

Back to top Go down

Something is wrong with image embedding Empty Re: Something is wrong with image embedding

Post by Soulmonster on Fri Mar 29, 2019 2:33 am

I just embedded an image in the post above, and it worked. It seems like the title of the thread affects whether it works or not. If the title contains a word that is contained in our database of automatically hyperlink words (like Slash or Izzy), then any images in that thread seems to conflict with the script. Can anyone else try to add an image to the recent thread '1991.09.DD - Rip It Up - Slash' so I can figure out if it is something with my computer.
Soulmonster
Soulmonster
Tour plane captain

Admin & Founder
Posts : 8775
Plectra : 55815
Reputation : 780
Join date : 2010-07-05

Back to top Go down

Something is wrong with image embedding Empty Re: Something is wrong with image embedding

Post by Blackstar on Fri Mar 29, 2019 4:33 am

@Soulmonster wrote:
@Blackstar wrote:Which posts? Is it with the "host image" feature?
I haven't had a problem, but I'm using the "insert image" feature.

Where do you host your images? I will try to host them somewhere else, and then use the "insert image" feature, too, and see if that solves it.

I use imgbox.com.

@Soulmonster wrote:I just embedded an image in the post above, and it worked. It seems like the title of the thread affects whether it works or not. If the title contains a word that is contained in our database of automatically hyperlink words (like Slash or Izzy), then any images in that thread seems to conflict with the script. Can anyone else try to add an image to the recent thread '1991.09.DD - Rip It Up - Slash' so I can figure out if it is something with my computer.

I just embedded two images from imgbox and it did it to me too. Odd, it hadn't done it before.

Blackstar
Blackstar
ADMIN

Posts : 1535
Plectra : 11686
Reputation : 66
Join date : 2018-03-17

Back to top Go down

Something is wrong with image embedding Empty Re: Something is wrong with image embedding

Post by Blackstar on Fri Mar 29, 2019 5:08 am

I added an interview with Gilby and it did it there with the images too.
Blackstar
Blackstar
ADMIN

Posts : 1535
Plectra : 11686
Reputation : 66
Join date : 2018-03-17

Back to top Go down

Something is wrong with image embedding Empty Re: Something is wrong with image embedding

Post by Soulmonster on Fri Mar 29, 2019 7:27 am

@Blackstar wrote:I added an interview with Gilby and it did it there with the images too.

I temporarily disable the script and now the images works as intended.

Obviously, something has been done with the underlying architecture that creates a conflict with images in threads with titles that includes keywords and a script for autolinks. I will see what I can figure out. In the mean time the autolink script will remain disabled.
Soulmonster
Soulmonster
Tour plane captain

Admin & Founder
Posts : 8775
Plectra : 55815
Reputation : 780
Join date : 2010-07-05

Back to top Go down

Something is wrong with image embedding Empty Re: Something is wrong with image embedding

Post by Soulmonster on Fri Mar 29, 2019 7:55 pm

I have started a thread about this on forumotion: https://help.forumotion.com/t157384-conflict-between-autolink-script-and-image-embedding
Soulmonster
Soulmonster
Tour plane captain

Admin & Founder
Posts : 8775
Plectra : 55815
Reputation : 780
Join date : 2010-07-05

Back to top Go down

Something is wrong with image embedding Empty Re: Something is wrong with image embedding

Post by Soulmonster on Fri Mar 29, 2019 7:57 pm

And I have turned the script on again for troubleshooting purposes. So apologies if an image is now not visible.

Worst case scenario is that we will have to disable the script permanently.
Soulmonster
Soulmonster
Tour plane captain

Admin & Founder
Posts : 8775
Plectra : 55815
Reputation : 780
Join date : 2010-07-05

Back to top Go down

Something is wrong with image embedding Empty Re: Something is wrong with image embedding

Post by Blackstar on Sat Mar 30, 2019 1:45 am

@Soulmonster wrote:I have started a thread about this on forumotion: https://help.forumotion.com/t157384-conflict-between-autolink-script-and-image-embedding

I went to the forumotion thread and I saw your screenshot.
It's not what it does to me. I can see the images, but also a part of the html code:

Something is wrong with image embedding OklCJqb6STSEw7Ts3Xgb+Clipboard01
Something is wrong with image embedding BPUJxtNRTqKMrPM3qLcM+Clipboard02

It's the same thing as when there's a url containing one of the autolink script words: The link is "clickable", but there is also the html code.
Blackstar
Blackstar
ADMIN

Posts : 1535
Plectra : 11686
Reputation : 66
Join date : 2018-03-17

Back to top Go down

Something is wrong with image embedding Empty Re: Something is wrong with image embedding

Post by Soulmonster on Sat Mar 30, 2019 7:50 am

Ok. Which browser are you using?

I am using Edge. I just tried it in Chrome, and I suppose I got the same result as you, I could see the image but parts of the link was visible.
Soulmonster
Soulmonster
Tour plane captain

Admin & Founder
Posts : 8775
Plectra : 55815
Reputation : 780
Join date : 2010-07-05

Back to top Go down

Something is wrong with image embedding Empty Re: Something is wrong with image embedding

Post by Blackstar on Sat Mar 30, 2019 8:48 am

@Soulmonster wrote:Ok. Which browser are you using?

I am using Edge. I just tried it in Chrome, and I suppose I got the same result as you, I could see the image but parts of the link was visible.

I use Chrome and Waterfox (similar to Firefox). Same result with both.
Blackstar
Blackstar
ADMIN

Posts : 1535
Plectra : 11686
Reputation : 66
Join date : 2018-03-17

Back to top Go down

Something is wrong with image embedding Empty Re: Something is wrong with image embedding

Post by Soulmonster on Sat Mar 30, 2019 9:24 am

@Blackstar wrote:
@Soulmonster wrote:Ok. Which browser are you using?

I am using Edge. I just tried it in Chrome, and I suppose I got the same result as you, I could see the image but parts of the link was visible.

I use Chrome and Waterfox (similar to Firefox). Same result with both.

Ok, thanks. Hopefully the guys at forumotion can help sort this out. But I don't think they are scripts experts. Might have to try to find someone somewhere else. Ideally, the script should also be improved so it doesn't include keywords found within links (so we don't have to use tinyurl all the time).
Soulmonster
Soulmonster
Tour plane captain

Admin & Founder
Posts : 8775
Plectra : 55815
Reputation : 780
Join date : 2010-07-05

Back to top Go down

Something is wrong with image embedding Empty Re: Something is wrong with image embedding

Post by Blackstar on Mon Apr 01, 2019 10:10 am

It somehow messes with the img tag. I tried posting just the address of the image, without the [img] tag, and it worked:
https://tinyurl.com/y4jb2jec

The problem is that, if the img tag conflict isn't solved, we'll have to go back to all the threads to remove the tag.
Blackstar
Blackstar
ADMIN

Posts : 1535
Plectra : 11686
Reputation : 66
Join date : 2018-03-17

Back to top Go down

Something is wrong with image embedding Empty Re: Something is wrong with image embedding

Post by Soulmonster on Mon Apr 01, 2019 5:56 pm

@Blackstar wrote:It somehow messes with the img tag. I tried posting just the address of the image, without the [img] tag, and it worked:
https://tinyurl.com/y4jb2jec

The problem is that, if the img tag conflict isn't solved, we'll have to go back to all the threads to remove the tag.

I think that if we can't fix the script I will disable it. It is more important to be able to embed images and have them shown properly in all browsers, than to have the autolink feature.
Soulmonster
Soulmonster
Tour plane captain

Admin & Founder
Posts : 8775
Plectra : 55815
Reputation : 780
Join date : 2010-07-05

Back to top Go down

Something is wrong with image embedding Empty Re: Something is wrong with image embedding

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum